首页 >> 科技 >> 不可修补的iOS漏洞可能导致iPhone 4s到iPhone

不可修补的iOS漏洞可能导致iPhone 4s到iPhone

发布时间: 2019-11-03 09:56:47来源:互联网 

今天,一名安全研究员公布了iphone 4s在iphone x之前的永久和不可修复的漏洞,这可能导致永久越狱。Twitter用户axi0mx今天共享了此漏洞,并将其命名为“checkm8”。如果这一弱点被进一步利用,它将导致史诗般的越狱。

Axi0mx说:“我今天发布的只是一个漏洞,不是支持cydia的越狱。对数亿ios设备来说,这是一个永久的、不可弥补的漏洞。从iphone 4s(a5芯片)到iphone 8和iphone x(a11芯片),大多数iphone和ipad都容易受到攻击。研究人员和开发人员可以使用它转储securerom,使用aes引擎解密密钥包,并降级设备以启用jtag。您仍然需要额外的硬件和软件来使用jtag。

在2018年夏天发布的ios 12测试版中,苹果修复了iboot usb代码中的一个严重缺陷。此漏洞只能由usb触发,需要物理访问。它不能远程使用。尽管苹果已经给了补丁,黑客们发现这个漏洞仍然可以被利用。黑客已经在github上发布了最新的漏洞和相关工具,并警告说利用此漏洞可能会导致设备变成砖块。

值得注意的是,苹果已经扩大了其漏洞奖励计划,并将于明年开始向开发者提供入狱前设备。这将提供苹果公司支持的前所未有的ios安全研究平台,该平台具有ssh、根壳和高级调试功能。

相关文章
整站热门


整站最新


栏目最新